Ivanovo Linux Users Group - Not logged in
Forum Help Search Login
Previous Next Up Topic Железо / Настраиваем железки / ac97_codec (7325 hits)
- By Ilya Date 07.01.06 09:32
Всех с наступившим и с Рождеством. Не давно вышло ядро 2.6.15 и я решил обновиться с 2.6.12.
Все хорошо, только нет звука в логах такая фигня:
Jan  6 01:10:17 darkstar kernel: snd: Unknown parameter `device_mode'
Jan  6 22:10:17 darkstar kernel: snd_seq_device: Unknown symbol snd_info_register
Jan  6 22:10:17 darkstar kernel: snd_seq_device: Unknown symbol snd_info_create_module_entry
Jan  6 22:10:17 darkstar kernel: snd_seq_device: Unknown symbol snd_info_free_entry
Jan  6 22:10:17 darkstar kernel: snd_seq_device: Unknown symbol snd_seq_root
Jan  6 22:10:17 darkstar kernel: snd_seq_device: Unknown symbol snd_verbose_printk
Jan  6 22:10:17 darkstar kernel: snd_seq_device: Unknown symbol snd_iprintf
Jan  6 22:10:17 darkstar kernel: snd_seq_device: Unknown symbol snd_device_new
Jan  6 22:10:17 darkstar kernel: snd_seq_device: Unknown symbol snd_info_unregister
Jan  6 22:10:17 darkstar kernel: snd_rawmidi: Unknown symbol snd_verbose_printd
и т.д.
Jan  6 22:10:17 darkstar kernel: snd_mpu422_uart: Unknown symbol snd_rawmidi_receive
и т.д.
Jan  6 22:10:17 darkstar kernel: snd_timer: Unknown symbol snd_verbose_printd
и т.д.
Jan  6 22:10:17 darkstar kernel: snd_pcm: Unknown symbol snd_verbose_printd
и т.д.
Jan  6 22:10:17 darkstar kernel: snd_ac97_codec: Unknown symbol snd_info_register
и т.д.
Jan  6 22:10:17 darkstar kernel: snd_via82xx: Unknown symbol snd_verbose_printd
и т.д.

Пробывал ядро 2.6.13 из slackware 10.2/test тоже самое.
С 2.6.12 все нормально.
Как лечить?
Parent - By LOE (Site/forum admin) Date 07.01.06 20:51
Как грузятся модули?
Случаем не через insmod? (надо через modprobe)
И вообще, если есть неотресолвленные ссылки, depmod -a скажет об этом.
Так что, думаю, некорректно сконфигурировано ядро.
или отключена автозагрузка модулей.
В общем причин - много.
У меня 2.6.14 (да и все другие 2.6.x) работает отлично. попробую 2.6.15 - сообщу результаты.
"No! Try not! Do. Or do not. There is no try." -- Yoda
Parent - By Ilya Date 08.01.06 09:59
root@darkstar:~# modprobe snd_via82xx
WARNING: Error inserting snd (/lib/modules/2.6.15/kernel/sound/acore/snd.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_seq_device (/lib/modules/2.6.15/kernel/sound/acore/seq/snd-seq-device.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_rawmidi (/lib/modules/2.6.15/kernel/sound/acore/snd-rawmidi.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_mpu401_uart (/lib/modules/2.6.15/kernel/sound/drivers/mpu401/snd-mpu401-uart.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_timer (/lib/modules/2.6.15/kernel/sound/acore/snd-timer.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_pcm (/lib/modules/2.6.15/kernel/sound/acore/snd-pcm.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_ac97_codec (/lib/modules/2.6.15/kernel/sound/pci/ac97/snd-ac97-codec.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting snd_via82xx (/lib/modules/2.6.15/kernel/sound/pci/snd-via82xx.ko): Unknown symbol in module, or unknown parameter (see dmesg)
root@darkstar:~# depmod -a
root@darkstar:~#
root@darkstar:~# dmesg
97_codec: Unknown symbol snd_info_register
snd_ac97_codec: Unknown symbol snd_ctl_add
snd_via82xx: Unknown symbol snd_verbose_printd
input: PC Speaker as /class/input/input2
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378 (0x778), irq 7 [PCSPP,TRISTATE,EPP]
ohci_hcd: 2005 April 22 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
IPv6 over IPv4 tunneling driver
process `named' is using obsolete setsockopt SO_BSDCOMPAT
snd: Unknown parameter `device_mode'
snd_seq_device: Unknown symbol snd_info_register
snd_rawmidi: Unknown symbol snd_verbose_printd
snd_mpu401_uart: Unknown symbol snd_rawmidi_receive
snd_timer: Unknown symbol snd_verbose_printd
snd_pcm: Unknown symbol snd_verbose_printd
snd_ac97_codec: Unknown symbol snd_info_register
snd_via82xx: Unknown symbol snd_verbose_printd
tun: Universal TUN/TAP device driver, 1.6
tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
ip_tables: (C) 2000-2002 Netfilter core team
ip_conntrack version 2.4 (2047 buckets, 16376 max) - 212 bytes per conntrack
NVRM: not using NVAGP, an AGPGART backend is loaded!
NVRM: not using NVAGP, an AGPGART backend is loaded!
CSLIP: code copyright 1989 Regents of the University of California
PPP generic driver version 2.4.2
PPP BSD Compression module registered
PPP Deflate Compression module registered
snd: Unknown parameter `device_mode'
snd_seq_device: Unknown symbol snd_info_register
snd_rawmidi: Unknown symbol snd_verbose_printd
snd_mpu401_uart: Unknown symbol snd_rawmidi_receive
snd_timer: Unknown symbol snd_verbose_printd
snd_pcm: Unknown symbol snd_verbose_printd
snd_ac97_codec: Unknown symbol snd_info_register
snd_via82xx: Unknown symbol snd_verbose_printd
root@darkstar:~#

вывод dmesg немного сократил за не надобностью.
На счет конфигурации ядра, может конечно с 2.6.15 я что-то и напутал
хоть и брал за основу рабочий конфиг от 2.6.12 которое сейчас у меня,
но не понятно почему 2.6.13(взял из slackware/test) выдает такую же фигню.
Сейчас попробую с другой звуковой платой (C-Media 8738 PCI) загрузить..
Parent By Ilya Date 08.01.06 11:31
Попробывал с другой звуковухой - то же самое.
Сейчас пересобираю ядро.
Parent By Ilya Date 08.01.06 12:29
В общем все настроил, помог alsaconf ;-)
Parent - By LOE (Site/forum admin) Date 08.01.06 19:15
Сначала надо depmod -a запустить, а уж потом - modprobe
Если modprobe ругается на "unknown symbol" - значит не удовлетворены зависимости. Т.е. или не загружены модули (а автоматическая подгрузка не сработала), или их нет (не установлены)

alsaconf тут (думаю) не помог. Помогла более корректная пересборка ядра.
"No! Try not! Do. Or do not. There is no try." -- Yoda
Parent By Ilya Date 09.01.06 07:08
Сначала надо depmod -a запустить, а уж потом - modprobe
Да так и так пробывал, все равно ругается.
Т.е. или не загружены модули (а автоматическая подгрузка не сработала), или их нет (не установлены)
Все модули звуковые из Alsa собирал, автоматическая подгрузку тоже указывал и она работала
т.к. ppp, fat'овские модули и т.д. подгружались нормально.
Когда пересобрал ядро, было тоже самое, только после alsaconf звук заработал.
Previous Next Up Topic Железо / Настраиваем железки / ac97_codec (7325 hits)

Powered by mwForum 2.12.0 © 1999-2007 Markus Wichitill

Page created in 0.073s with 10 database queries.